ERROR: Failed building wheel for twisted-iocpsupport

error image

I was trying to install daphne===4.0.0 but I keep getting this error, ERROR: Failed building wheel for twisted-iocpsupport

Building wheels for collected packages: twisted-iocpsupport

Building wheel for twisted-iocpsupport (pyproject.toml) ... error error: subprocess-exited-with-error

× Building wheel for twisted-iocpsupport (pyproject.toml) did not run successfully. │ exit code: 1 ╰─> [5 lines of output] running bdist_wheel running build running build_ext building 'twisted_iocpsupport.iocpsupport' extension error: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/ [end of output]

note: This error originates from a subprocess, and is likely not a problem with pip. ERROR: Failed building wheel for twisted-iocpsupport Failed to build twisted-iocpsupport ERROR: Could not build wheels for twisted-iocpsupport, which is required to install pyproject.toml-based projects

This error occurs because twisted-iocpsupport is not supported by python 3.11 Consider going back to any versions between 3.6 and 3.10 that fixed the problem for me. Go to twisted-iocpsupport documentation and see the versions of python it supports

According to the docs,

Applications must not import names from the twisted_iocpsupport package directly.

So, if you're using any file with package versioning (requirements.txt, project.toml, etc.), you should remove-it manually.

Back to Top