Новости Джанго

Исправления ошибок Django: 2.1.4 и 1.11.17

Сегодня команда разработчиков Django выпустила версии 2.1.4 и 1.11.17 с исправлениями ошибок.

Версия 2.1.4:

  • Исправлен список паролей по умолчанию который использует CommonPasswordValidator, приводя все символы к нижнему регистру, ожидаемому валидатором (#29952).
  • Предотвращение повторных вызовов geos_version_tuple() в классе WKBWriter в попытке исправить случайный сбой с использованием LooseVersion (#29959).
  • Исправлена поддержка keep-alive в команде runserver после того, как она была отключена для исправления другой проблемы в Django 2.0 (#29849).
  • Исправлена ошибка смены формы с правами администратора при использовании ModelAdmin.prepopulated_fields  (#29929).
  • Исправлено сообщение об ошибке «Пожалуйста, исправьте ошибки ниже» при редактировании объекта в админке, если у пользователя есть только разрешение «просмотр» на inline-объектах (#29930).

Версия 1.11.17:

  • Предотвращение повторных вызовов geos_version_tuple() в классе WKBWriter в попытке исправить случайный сбой с использованием LooseVersion (#29959).

Пакеты и контрольные суммы доступны на странице загрузок, также как в Python Package Index. PGP key ID этого релиза от Carlton Gibson: E17DF5C82B4F9D00.

 

Поделитесь с другими: