Two packages require two different python versions on django deployment on centos7?

I'm trying to deploy my django project on Centos 7. While installing pip -r install requirements.txt I got error and I somehow tried to solve it. First of all it is said that asgiref==3.5.0 can't be installed in Python 3.7 below. Default installed python version is 3.6.8. Then I install python 3.7 and asgiref problem is solved, but I got another error on coreschema==0.0.4 (which is in requirements.txt). I upload image below, but looking at pypi I thought that coreschema is not supported on python 3.6 above. If this is the issue, how to solve it?

enter image description here

It is possible to install coreschema with pip or pip3, because their python version is below than 3.7

Back to Top